summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-cmd2_0.8.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python-cmd2_0.8.8.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-cmd2_0.8.8.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-cmd2_0.8.8.bb b/meta-python/recipes-devtools/python/python-cmd2_0.8.8.bb
new file mode 100644
index 0000000000..b3bea82c93
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-cmd2_0.8.8.bb
@@ -0,0 +1,23 @@
1SUMMARY = "Extra features for standard library's cmd module"
2HOMEPAGE = "http://packages.python.org/cmd2/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=60bc6842001870a418935bd84570b676"
5
6SRC_URI[md5sum] = "1f555bb656d361d9b0212b07e232752f"
7SRC_URI[sha256sum] = "b08bc5088fdd131d659354e6b4f8cf7c01a70566f68aed146e00d296a24b687b"
8
9inherit pypi setuptools
10
11RDEPENDS_${PN} += "\
12 ${PYTHON_PN}-doctest \
13 ${PYTHON_PN}-pyparsing \
14 ${PYTHON_PN}-pyperclip \
15 ${PYTHON_PN}-shell \
16 ${PYTHON_PN}-six \
17 ${PYTHON_PN}-stringold \
18 ${PYTHON_PN}-subprocess \
19 ${PYTHON_PN}-threading \
20 ${PYTHON_PN}-textutils \
21 "
22
23BBCLASSEXTEND = "native nativesdk"