summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-cryptography_1.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python-cryptography_1.4.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-cryptography_1.4.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-cryptography_1.4.bb b/meta-python/recipes-devtools/python/python-cryptography_1.4.bb
new file mode 100644
index 0000000000..a6b5bd0888
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-cryptography_1.4.bb
@@ -0,0 +1,49 @@
1SUMMARY = "Provides cryptographic recipes and primitives to Python developers"
2LICENSE = "Apache-2.0 | BSD"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=8c3617db4fb6fae01f1d253ab91511e4"
4DEPENDS += " python-cffi-native python-cffi python-enum34 python-six python-pyasn1"
5SRCNAME = "cryptography"
6
7SRC_URI = "file://run-ptest"
8
9SRC_URI[md5sum] = "a9763e3831cc7cdb402c028fac1ceb39"
10SRC_URI[sha256sum] = "bb149540ed90c4b2171bf694fe6991d6331bc149ae623c8ff419324f4222d128"
11
12inherit pypi setuptools
13
14RDEPENDS_${PN} = "\
15 python-pyasn1\
16 python-six\
17 python-cffi\
18 python-enum34\
19 python-setuptools\
20 python-pycparser\
21 python-subprocess\
22 python-threading\
23 python-numbers\
24 python-contextlib\
25 python-ipaddress\
26 python-pyasn1\
27 python-idna\
28"
29
30RDEPENDS_${PN}-ptest = "\
31 ${PN}\
32 python-pytest\
33 python-pretend\
34 python-iso8601\
35 python-cryptography-vectors\
36"
37
38inherit ptest
39
40do_install_ptest() {
41 install -d ${D}${PTEST_PATH}/tests
42 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
43 install -d ${D}${PTEST_PATH}/tests/hazmat
44 cp -rf ${S}/tests/hazmat/* ${D}${PTEST_PATH}/tests/hazmat/
45}
46
47FILES_${PN}-dbg += " \
48 ${libdir}/python2.7/site-packages/${SRCNAME}/hazmat/bindings/.debug \
49 "