summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-dbus_1.2.14.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python-dbus_1.2.14.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-dbus_1.2.14.bb32
1 files changed, 0 insertions, 32 deletions
diff --git a/meta-python/recipes-devtools/python/python-dbus_1.2.14.bb b/meta-python/recipes-devtools/python/python-dbus_1.2.14.bb
deleted file mode 100644
index b89d7d2c8b..0000000000
--- a/meta-python/recipes-devtools/python/python-dbus_1.2.14.bb
+++ /dev/null
@@ -1,32 +0,0 @@
1SUMMARY = "Python bindings for the DBus inter-process communication system"
2SECTION = "devel/python"
3HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
4LICENSE = "MIT & AFL-2.1 | GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b03240518994df6d8c974675675e5ca4 \
6 file://dbus-gmain/COPYING;md5=99fece6728a80737c8fd3e7c734c17c4 "
7DEPENDS = "expat dbus dbus-glib virtual/libintl python-pyrex-native"
8
9SRC_URI = "http://dbus.freedesktop.org/releases/dbus-python/dbus-python-${PV}.tar.gz \
10"
11
12SRC_URI[md5sum] = "c8739234fca9fba26368d1a337abe830"
13SRC_URI[sha256sum] = "b10206ba3dd641e4e46411ab91471c88e0eec1749860e4285193ee68df84ac31"
14S = "${WORKDIR}/dbus-python-${PV}"
15
16inherit distutils-base autotools pkgconfig
17
18# documentation needs python-sphinx, which is not in oe-core or meta-python for now
19# change to use PACKAGECONFIG when python-sphinx is added to oe-core or meta-python
20EXTRA_OECONF += "--disable-documentation"
21
22export STAGING_LIBDIR
23export STAGING_INCDIR
24
25RDEPENDS_${PN} = "python-io python-logging python-stringold python-threading python-xml"
26
27FILES_${PN}-dev += "${libdir}/pkgconfig"
28
29do_install_append() {
30 # Remove files that clash with python3-dbus; their content is same
31 rm ${D}${includedir}/dbus-1.0/dbus/dbus-python.h ${D}${libdir}/pkgconfig/dbus-python.pc
32}