summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-dbusmock_0.16.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python-dbusmock_0.16.6.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-dbusmock_0.16.6.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-dbusmock_0.16.6.bb b/meta-python/recipes-devtools/python/python-dbusmock_0.16.6.bb
new file mode 100644
index 0000000000..4b3d2011e2
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-dbusmock_0.16.6.bb
@@ -0,0 +1,26 @@
1# Copyright (c) 2014 LG Electronics, Inc.
2
3SUMMARY = "With this program/Python library you can easily create mock objects on D-Bus"
4AUTHOR = "Martin Pitt <martin.pitt@ubuntu.com>"
5
6LICENSE = "GPL-3.0"
7LIC_FILES_CHKSUM = "file://COPYING;md5=e6a600fd5e1d9cbde2d983680233ad02"
8
9SRC_URI[md5sum] = "6af369964653098f2cd5e7c4e060a533"
10SRC_URI[sha256sum] = "87c551030369005a6c818d9f27e931090bff837e70af060b65281e9ea77108cf"
11
12SRC_URI += " \
13 file://0001-Add-functionality-to-add-own-objects-to-internal-obj.patch \
14 file://0002-Add-possibility-to-import-templates-from-packages.patch \
15"
16
17PYPI_PACKAGE = "python-dbusmock"
18
19inherit pypi setuptools
20
21RDEPENDS_${PN} += "\
22 ${PYTHON_PN}-dbus \
23 ${PYTHON_PN}-importlib \
24 ${PYTHON_PN}-pygobject \
25 ${PYTHON_PN}-xml \
26 "