diff options
Diffstat (limited to 'meta-python/recipes-devtools/python/python-grpcio')
2 files changed, 21 insertions, 7 deletions
diff --git a/meta-python/recipes-devtools/python/python-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch b/meta-python/recipes-devtools/python/python-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch index 996597b146..f17f048de8 100644 --- a/meta-python/recipes-devtools/python/python-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch +++ b/meta-python/recipes-devtools/python/python-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch | |||
@@ -18,11 +18,9 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com> | |||
18 | setup.py | 2 +- | 18 | setup.py | 2 +- |
19 | 1 file changed, 1 insertion(+), 1 deletion(-) | 19 | 1 file changed, 1 insertion(+), 1 deletion(-) |
20 | 20 | ||
21 | Index: grpcio-1.14.1/setup.py | 21 | --- a/setup.py |
22 | =================================================================== | 22 | +++ b/setup.py |
23 | --- grpcio-1.14.1.orig/setup.py | 23 | @@ -145,7 +145,7 @@ ENABLE_DOCUMENTATION_BUILD = os.environ. |
24 | +++ grpcio-1.14.1/setup.py | ||
25 | @@ -123,7 +123,7 @@ ENABLE_DOCUMENTATION_BUILD = os.environ. | ||
26 | EXTRA_ENV_COMPILE_ARGS = os.environ.get('GRPC_PYTHON_CFLAGS', None) | 24 | EXTRA_ENV_COMPILE_ARGS = os.environ.get('GRPC_PYTHON_CFLAGS', None) |
27 | EXTRA_ENV_LINK_ARGS = os.environ.get('GRPC_PYTHON_LDFLAGS', None) | 25 | EXTRA_ENV_LINK_ARGS = os.environ.get('GRPC_PYTHON_LDFLAGS', None) |
28 | if EXTRA_ENV_COMPILE_ARGS is None: | 26 | if EXTRA_ENV_COMPILE_ARGS is None: |
@@ -31,7 +29,7 @@ Index: grpcio-1.14.1/setup.py | |||
31 | if 'win32' in sys.platform and sys.version_info < (3, 5): | 29 | if 'win32' in sys.platform and sys.version_info < (3, 5): |
32 | EXTRA_ENV_COMPILE_ARGS += ' -D_hypot=hypot' | 30 | EXTRA_ENV_COMPILE_ARGS += ' -D_hypot=hypot' |
33 | # We use define flags here and don't directly add to DEFINE_MACROS below to | 31 | # We use define flags here and don't directly add to DEFINE_MACROS below to |
34 | @@ -135,7 +135,7 @@ if EXTRA_ENV_COMPILE_ARGS is None: | 32 | @@ -157,7 +157,7 @@ if EXTRA_ENV_COMPILE_ARGS is None: |
35 | else: | 33 | else: |
36 | EXTRA_ENV_COMPILE_ARGS += ' -D_ftime=_ftime64 -D_timeb=__timeb64' | 34 | EXTRA_ENV_COMPILE_ARGS += ' -D_ftime=_ftime64 -D_timeb=__timeb64' |
37 | elif "linux" in sys.platform: | 35 | elif "linux" in sys.platform: |
@@ -39,4 +37,4 @@ Index: grpcio-1.14.1/setup.py | |||
39 | + EXTRA_ENV_COMPILE_ARGS += ' -fvisibility=hidden -fno-wrapv -fno-exceptions' | 37 | + EXTRA_ENV_COMPILE_ARGS += ' -fvisibility=hidden -fno-wrapv -fno-exceptions' |
40 | elif "darwin" in sys.platform: | 38 | elif "darwin" in sys.platform: |
41 | EXTRA_ENV_COMPILE_ARGS += ' -fvisibility=hidden -fno-wrapv -fno-exceptions' | 39 | EXTRA_ENV_COMPILE_ARGS += ' -fvisibility=hidden -fno-wrapv -fno-exceptions' |
42 | EXTRA_ENV_COMPILE_ARGS += ' -DPB_FIELD_16BIT' | 40 | EXTRA_ENV_COMPILE_ARGS += ' -DPB_FIELD_32BIT' |
diff --git a/meta-python/recipes-devtools/python/python-grpcio/riscv64_support.patch b/meta-python/recipes-devtools/python/python-grpcio/riscv64_support.patch new file mode 100644 index 0000000000..fef7d9e757 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-grpcio/riscv64_support.patch | |||
@@ -0,0 +1,16 @@ | |||
1 | Add RISC-V 64bit support | ||
2 | |||
3 | Upstream-Status: Pending | ||
4 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
5 | --- a/third_party/boringssl/include/openssl/base.h | ||
6 | +++ b/third_party/boringssl/include/openssl/base.h | ||
7 | @@ -104,6 +104,9 @@ extern "C" { | ||
8 | #elif defined(__mips__) && defined(__LP64__) | ||
9 | #define OPENSSL_64_BIT | ||
10 | #define OPENSSL_MIPS64 | ||
11 | +#elif defined(__riscv) && defined(__riscv_xlen) | ||
12 | +#define OPENSSL_64_BIT | ||
13 | +#define OPENSSL_RISCV64 | ||
14 | #elif defined(__pnacl__) | ||
15 | #define OPENSSL_32_BIT | ||
16 | #define OPENSSL_PNACL | ||