diff options
Diffstat (limited to 'meta-python/recipes-devtools/python/python-imaging_1.1.7.bb')
-rw-r--r-- | meta-python/recipes-devtools/python/python-imaging_1.1.7.bb | 45 |
1 files changed, 45 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-imaging_1.1.7.bb b/meta-python/recipes-devtools/python/python-imaging_1.1.7.bb new file mode 100644 index 0000000000..a678328275 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-imaging_1.1.7.bb | |||
@@ -0,0 +1,45 @@ | |||
1 | SUMMARY = "Python Imaging Library (PIL)" | ||
2 | SECTION = "devel/python" | ||
3 | LICENSE = "MIT" | ||
4 | LIC_FILES_CHKSUM = "file://README;beginline=92;endline=120;md5=c4371af4579f1e489cf881c1443dd4ec" | ||
5 | DEPENDS = "freetype jpeg tiff" | ||
6 | SRCNAME = "Imaging" | ||
7 | PR = "r5" | ||
8 | |||
9 | SRC_URI = "http://effbot.org/downloads/Imaging-${PV}.tar.gz \ | ||
10 | file://0001-python-imaging-setup.py-force-paths-for-zlib-freetyp.patch \ | ||
11 | file://allow.to.disable.some.features.patch \ | ||
12 | file://fix-freetype-includes.patch" | ||
13 | |||
14 | SRC_URI[md5sum] = "fc14a54e1ce02a0225be8854bfba478e" | ||
15 | SRC_URI[sha256sum] = "895bc7c2498c8e1f9b99938f1a40dc86b3f149741f105cf7c7bd2e0725405211" | ||
16 | S = "${WORKDIR}/${SRCNAME}-${PV}" | ||
17 | |||
18 | # There isn't enable/disable option, and lcms is in meta-oe, at least make it explicit when enabled | ||
19 | # setup.py already has FIXME: add mechanism to explicitly *disable* the use of a library | ||
20 | PACKAGECONFIG ??= "" | ||
21 | PACKAGECONFIG[lcms] = ",,lcms" | ||
22 | |||
23 | inherit distutils | ||
24 | |||
25 | do_compile() { | ||
26 | export STAGING_LIBDIR=${STAGING_LIBDIR} | ||
27 | export STAGING_INCDIR=${STAGING_INCDIR} | ||
28 | export LCMS_ENABLED=${@bb.utils.contains('PACKAGECONFIG', 'lcms', 'True', 'False', d)} | ||
29 | distutils_do_compile | ||
30 | } | ||
31 | |||
32 | do_install() { | ||
33 | export STAGING_LIBDIR=${STAGING_LIBDIR} | ||
34 | export STAGING_INCDIR=${STAGING_INCDIR} | ||
35 | export LCMS_ENABLED=${@bb.utils.contains('PACKAGECONFIG', 'lcms', 'True', 'False', d)} | ||
36 | distutils_do_install | ||
37 | install -d ${D}${datadir}/doc/${BPN}/html/ | ||
38 | install -m 0644 ${S}/README ${D}${datadir}/doc/${BPN}/ | ||
39 | install -m 0644 ${S}/Docs/* ${D}${datadir}/doc/${BPN}/html/ | ||
40 | |||
41 | # get rid of #!/usr/local/bin/python | ||
42 | sed -i -e 's:/usr/local/bin/:${bindir}/env :g' ${D}${bindir}/* | ||
43 | } | ||
44 | |||
45 | RDEPENDS_${PN} += "python-lang python-stringold" | ||