diff options
Diffstat (limited to 'meta-python/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch')
-rw-r--r-- | meta-python/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch | 35 |
1 files changed, 0 insertions, 35 deletions
diff --git a/meta-python/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch b/meta-python/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch deleted file mode 100644 index b339d93f75..0000000000 --- a/meta-python/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch +++ /dev/null | |||
@@ -1,35 +0,0 @@ | |||
1 | From dfb83a41aaeae326e9b6f02b233af375bc7b8815 Mon Sep 17 00:00:00 2001 | ||
2 | From: Koen Kooi <koen@dominion.thruhere.net> | ||
3 | Date: Fri, 29 Mar 2013 15:17:17 +0100 | ||
4 | Subject: [PATCH] setup.py: link in sysroot, not in host directories | ||
5 | |||
6 | Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> | ||
7 | |||
8 | Upstream-status: Unknown | ||
9 | --- | ||
10 | setup.py | 6 +++--- | ||
11 | 1 file changed, 3 insertions(+), 3 deletions(-) | ||
12 | |||
13 | Index: M2Crypto-0.30.1/setup.py | ||
14 | =================================================================== | ||
15 | --- M2Crypto-0.30.1.orig/setup.py | ||
16 | +++ M2Crypto-0.30.1/setup.py | ||
17 | @@ -130,6 +130,7 @@ class _M2CryptoBuildExt(build_ext.build_ | ||
18 | self.set_undefined_options('build', ('bundledlls', 'bundledlls')) | ||
19 | |||
20 | self.libraries = ['ssl', 'crypto'] | ||
21 | + self.openssl = os.environ.get( "STAGING_DIR" ) | ||
22 | if sys.platform == 'win32': | ||
23 | self.libraries = ['ssleay32', 'libeay32'] | ||
24 | if self.openssl and openssl_version(self.openssl, 0x10100000, True): | ||
25 | @@ -150,8 +151,8 @@ class _M2CryptoBuildExt(build_ext.build_ | ||
26 | |||
27 | if self.openssl is not None: | ||
28 | log.debug('self.openssl = %s', self.openssl) | ||
29 | - openssl_library_dir = os.path.join(self.openssl, 'lib') | ||
30 | - openssl_include_dir = os.path.join(self.openssl, 'include') | ||
31 | + openssl_library_dir = os.environ.get( "STAGING_LIBDIR" ) | ||
32 | + openssl_include_dir = os.environ.get( "STAGING_INCDIR" ) | ||
33 | |||
34 | self.library_dirs.append(openssl_library_dir) | ||
35 | self.include_dirs.append(openssl_include_dir) | ||