diff options
Diffstat (limited to 'meta-python/recipes-devtools/python/python-m2crypto/cross-compile-platform.patch')
-rw-r--r-- | meta-python/recipes-devtools/python/python-m2crypto/cross-compile-platform.patch | 30 |
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-m2crypto/cross-compile-platform.patch b/meta-python/recipes-devtools/python/python-m2crypto/cross-compile-platform.patch new file mode 100644 index 0000000000..c6654e5402 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-m2crypto/cross-compile-platform.patch | |||
@@ -0,0 +1,30 @@ | |||
1 | Do not compute platform, this does not work in cross compile environment | ||
2 | since it pokes at the system for getting architecture values | ||
3 | |||
4 | Upstream-Status: Inappropriate | ||
5 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
6 | |||
7 | Index: M2Crypto-0.26.0/setup.py | ||
8 | =================================================================== | ||
9 | --- M2Crypto-0.26.0.orig/setup.py | ||
10 | +++ M2Crypto-0.26.0/setup.py | ||
11 | @@ -141,19 +141,6 @@ class _M2CryptoBuildExt(build_ext.build_ | ||
12 | self.include_dirs.append( | ||
13 | os.path.join(self.openssl, 'include', 'openssl')) | ||
14 | |||
15 | - # For RedHat-based distros, the '-D__{arch}__' option for | ||
16 | - # Swig needs to be normalized, particularly on i386. | ||
17 | - mach = platform.machine().lower() | ||
18 | - if mach in ('i386', 'i486', 'i586', 'i686'): | ||
19 | - arch = '__i386__' | ||
20 | - elif mach in ('ppc64', 'powerpc64'): | ||
21 | - arch = '__powerpc64__' | ||
22 | - elif mach in ('ppc', 'powerpc'): | ||
23 | - arch = '__powerpc__' | ||
24 | - else: | ||
25 | - arch = '__%s__' % mach | ||
26 | - self.swig_opts.append('-D%s' % arch) | ||
27 | - | ||
28 | self.swig_opts.extend(['-I%s' % i for i in self.include_dirs]) | ||
29 | self.swig_opts.append('-includeall') | ||
30 | self.swig_opts.append('-modern') | ||