summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-pygpgme_0.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python-pygpgme_0.3.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-pygpgme_0.3.bb26
1 files changed, 0 insertions, 26 deletions
diff --git a/meta-python/recipes-devtools/python/python-pygpgme_0.3.bb b/meta-python/recipes-devtools/python/python-pygpgme_0.3.bb
deleted file mode 100644
index 14e967db88..0000000000
--- a/meta-python/recipes-devtools/python/python-pygpgme_0.3.bb
+++ /dev/null
@@ -1,26 +0,0 @@
1SUMMARY = "A Python module for working with OpenPGP messages"
2DESCRIPTION = "PyGPGME is a Python module that lets you sign, verify, \
3 encrypt and decrypt messages using the OpenPGP format."
4HOMEPAGE = "https://launchpad.net/pygpgme"
5
6LICENSE = "LGPL-2.1"
7LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=6517bdc8f2416f27ab725d4702f7aac3"
8
9SRC_URI = "file://run-ptest \
10 file://0001-reflect-2.1-reporting-for-key-imports.patch \
11 file://0002-passphrase_cb-is-deprecated.patch \
12 file://0003-handle-generic-error-when-no-passphrase-callback-pre.patch \
13"
14
15SRC_URI[md5sum] = "d38355af73f0352cde3d410b25f34fd0"
16SRC_URI[sha256sum] = "5fd887c407015296a8fd3f4b867fe0fcca3179de97ccde90449853a3dfb802e1"
17
18DEPENDS += "gpgme"
19RDEPENDS_${PN} += "gnupg"
20
21inherit pypi setuptools ptest
22
23do_install_ptest(){
24 install ${S}/test_all.py ${D}${PTEST_PATH}
25 cp -r ${S}/tests ${D}${PTEST_PATH}
26}