summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-aiohttp_3.10.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-aiohttp_3.10.3.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-aiohttp_3.10.3.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-aiohttp_3.10.3.bb b/meta-python/recipes-devtools/python/python3-aiohttp_3.10.3.bb
new file mode 100644
index 0000000000..a2cfe7173c
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-aiohttp_3.10.3.bb
@@ -0,0 +1,22 @@
1SUMMARY = "Async http client/server framework"
2DESCRIPTION = "Asynchronous HTTP client/server framework for asyncio and Python"
3HOMEPAGE = "https://github.com/aio-libs/aiohttp"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=748073912af33aa59430d3702aa32d41"
6
7SRC_URI[sha256sum] = "21650e7032cc2d31fc23d353d7123e771354f2a3d5b05a5647fc30fea214e696"
8
9PYPI_PACKAGE = "aiohttp"
10inherit python_setuptools_build_meta pypi
11
12RDEPENDS:${PN} = "\
13 python3-aiohappyeyeballs \
14 python3-aiosignal \
15 python3-async-timeout \
16 python3-attrs \
17 python3-frozenlist \
18 python3-misc \
19 python3-multidict \
20 python3-yarl \
21 python3-aiodns \
22"