summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-aiohttp_3.8.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-aiohttp_3.8.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-aiohttp_3.8.0.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-aiohttp_3.8.0.bb b/meta-python/recipes-devtools/python/python3-aiohttp_3.8.0.bb
new file mode 100644
index 0000000000..710f8f4ceb
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-aiohttp_3.8.0.bb
@@ -0,0 +1,23 @@
1SUMMARY = "Async http client/server framework"
2DESCRIPTION = "Asynchronous HTTP client/server framework for asyncio and Python"
3HOMEPAGE = "https://github.com/aio-libs/aiohttp"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=8074d6c6e217873b2a018a4522243ea3"
6
7SRC_URI[sha256sum] = "d3b19d8d183bcfd68b25beebab8dc3308282fe2ca3d6ea3cb4cd101b3c279f8d"
8
9PYPI_PACKAGE = "aiohttp"
10inherit setuptools3 pypi
11RDEPENDS:${PN} = "\
12 ${PYTHON_PN}-async-timeout \
13 ${PYTHON_PN}-attrs \
14 ${PYTHON_PN}-chardet \
15 ${PYTHON_PN}-html \
16 ${PYTHON_PN}-idna-ssl \
17 ${PYTHON_PN}-json \
18 ${PYTHON_PN}-misc \
19 ${PYTHON_PN}-multidict \
20 ${PYTHON_PN}-netserver \
21 ${PYTHON_PN}-typing-extensions \
22 ${PYTHON_PN}-yarl \
23"