summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-anyjson/0001-setup.py-Do-not-use-2to3.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-anyjson/0001-setup.py-Do-not-use-2to3.patch')
-rw-r--r--meta-python/recipes-devtools/python/python3-anyjson/0001-setup.py-Do-not-use-2to3.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-anyjson/0001-setup.py-Do-not-use-2to3.patch b/meta-python/recipes-devtools/python/python3-anyjson/0001-setup.py-Do-not-use-2to3.patch
new file mode 100644
index 0000000000..2b9e6e52e8
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-anyjson/0001-setup.py-Do-not-use-2to3.patch
@@ -0,0 +1,29 @@
1From 4fb61d7c621599b0db9c2c45f4243f07936c5953 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 13 Oct 2021 08:20:00 -0700
4Subject: [PATCH] setup.py: Do not use 2to3
5
6This helps compiling with setuptools 0.58+
7and it seems to compile fine with python3
8
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10---
11 setup.py | 2 --
12 1 file changed, 2 deletions(-)
13
14diff --git a/setup.py b/setup.py
15index 9fe4902..f2098e1 100644
16--- a/setup.py
17+++ b/setup.py
18@@ -2,8 +2,6 @@ import os
19 import sys
20
21 extra = {}
22-if sys.version_info >= (3, 0):
23- extra.update(use_2to3=True)
24
25 try:
26 from setuptools import setup, find_packages
27--
282.33.0
29