summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-aspectlib_1.5.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-aspectlib_1.5.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-aspectlib_1.5.2.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-aspectlib_1.5.2.bb b/meta-python/recipes-devtools/python/python3-aspectlib_1.5.2.bb
new file mode 100644
index 0000000000..415a430672
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-aspectlib_1.5.2.bb
@@ -0,0 +1,15 @@
1# Copyright (C) 2021 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "``aspectlib`` is an aspect-oriented programming, monkey-patch and decorators library. It is useful when changing"
5HOMEPAGE = "https://github.com/ionelmc/python-aspectlib"
6LICENSE = "BSD-2-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=d58b3f20fd10347a9458b8a03793b62e"
8
9SRC_URI[sha256sum] = "d275ec82c4c2712e564bb760e4accff8f061f648e38774feabeb8b241cf3a4aa"
10
11inherit pypi setuptools3
12
13RDEPENDS_${PN} += "python3-core python3-fields"
14
15BBCLASSEXTEND = "native nativesdk"