summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-async-timeout_4.0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-async-timeout_4.0.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-async-timeout_4.0.0.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-async-timeout_4.0.0.bb b/meta-python/recipes-devtools/python/python3-async-timeout_4.0.0.bb
new file mode 100644
index 0000000000..ca61490fac
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-async-timeout_4.0.0.bb
@@ -0,0 +1,18 @@
1SUMMARY = "asyncio-compatible timeout context manager"
2DESCRIPTION = "\
3The context manager is useful in cases when you want to apply \
4timeout logic around block of code or in cases when asyncio.wait_for() \
5is not suitable. Also it's much faster than asyncio.wait_for() because \
6timeout doesn't create a new task."
7HOMEPAGE = "https://github.com/aio-libs/async-timeout"
8LICENSE = "Apache-2.0"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=4fa41f15bb5f23b6d3560c5845eb8d57"
10
11SRC_URI[sha256sum] = "7d87a4e8adba8ededb52e579ce6bc8276985888913620c935094c2276fd83382"
12
13PYPI_PACKAGE = "async-timeout"
14inherit pypi setuptools3
15
16RDEPENDS:${PN} = "\
17 ${PYTHON_PN}-asyncio \
18"