diff options
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-aws-iot-device-sdk-python_1.4.8.bb')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-aws-iot-device-sdk-python_1.4.8.bb | 41 |
1 files changed, 41 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-aws-iot-device-sdk-python_1.4.8.bb b/meta-python/recipes-devtools/python/python3-aws-iot-device-sdk-python_1.4.8.bb new file mode 100644 index 0000000000..f763067cf0 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-aws-iot-device-sdk-python_1.4.8.bb | |||
@@ -0,0 +1,41 @@ | |||
1 | DESCRIPTION = "SDK for connecting to AWS IoT using Python." | ||
2 | HOMEPAGE = "https://github.com/aws/aws-iot-device-sdk-python" | ||
3 | LICENSE = "Apache-2.0 & (EPL-1.0 | EDL-1.0)" | ||
4 | LICENSE_${PN}-examples = "Apache-2.0" | ||
5 | LIC_FILES_CHKSUM = "\ | ||
6 | file://LICENSE.txt;md5=9ac49901b833e769c7d6f21e8dbd7b30 \ | ||
7 | file://AWSIoTPythonSDK/core/protocol/paho/client.py;endline=14;md5=5a3c8a1a4bb71bd934f450ecff972ad9 \ | ||
8 | " | ||
9 | |||
10 | SRC_URI[md5sum] = "d05596f02774ea39517765c5dced874a" | ||
11 | SRC_URI[sha256sum] = "bcd68cb7fdb044dbd5e5d3a02c311b25717c0376168e7c992982130f19c51b03" | ||
12 | |||
13 | inherit pypi setuptools3 | ||
14 | |||
15 | PYPI_PACKAGE = "AWSIoTPythonSDK" | ||
16 | |||
17 | do_install_append() { | ||
18 | install -d -m0755 ${D}${datadir}/${BPN}/examples | ||
19 | cp --preserve=mode,timestamps -R ${S}/samples/* ${D}${datadir}/${BPN}/examples | ||
20 | # this requires the full blown AWS Python SDK | ||
21 | rm -r ${D}${datadir}/${BPN}/examples/basicPubSub | ||
22 | } | ||
23 | |||
24 | PACKAGES =+ "${PN}-examples" | ||
25 | |||
26 | RDEPENDS_${PN} += " \ | ||
27 | ${PYTHON_PN}-crypt \ | ||
28 | ${PYTHON_PN}-datetime \ | ||
29 | ${PYTHON_PN}-io \ | ||
30 | ${PYTHON_PN}-json \ | ||
31 | ${PYTHON_PN}-logging \ | ||
32 | ${PYTHON_PN}-math \ | ||
33 | ${PYTHON_PN}-netclient \ | ||
34 | ${PYTHON_PN}-numbers \ | ||
35 | ${PYTHON_PN}-threading \ | ||
36 | " | ||
37 | RDEPENDS_${PN}-examples += "${PN}" | ||
38 | |||
39 | FILES_${PN}-examples = "${datadir}/${BPN}/examples" | ||
40 | |||
41 | BBCLASSEXTEND = "native nativesdk" | ||