summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-bleak/0001-fix-poetry-version-compatibility.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-bleak/0001-fix-poetry-version-compatibility.patch')
-rw-r--r--meta-python/recipes-devtools/python/python3-bleak/0001-fix-poetry-version-compatibility.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-bleak/0001-fix-poetry-version-compatibility.patch b/meta-python/recipes-devtools/python/python3-bleak/0001-fix-poetry-version-compatibility.patch
new file mode 100644
index 0000000000..cc568146dd
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-bleak/0001-fix-poetry-version-compatibility.patch
@@ -0,0 +1,21 @@
1--- a/pyproject.toml 2023-04-19 19:04:47.159474100 -0300
2+++ b/pyproject.toml 2023-05-04 08:08:12.289941765 -0300
3@@ -31,15 +31,15 @@
4 bleak-winrt = { version = "^1.2.0", markers = "platform_system=='Windows'" }
5 dbus-fast = { version = "^1.83.0", markers = "platform_system == 'Linux'" }
6
7-[tool.poetry.group.docs.dependencies]
8+#[tool.poetry.group.docs.dependencies]
9 Sphinx = { version = "^5.1.1", python = ">=3.8" }
10 sphinx-rtd-theme = "^1.0.0"
11
12-[tool.poetry.group.lint.dependencies]
13+#[tool.poetry.group.lint.dependencies]
14 black = "^22.1.0"
15 flake8 = { version = "^5.0.0", python = ">=3.8" }
16
17-[tool.poetry.group.test.dependencies]
18+#[tool.poetry.group.test.dependencies]
19 asynctest = { version = "^0.13.0", python = "<3.8" }
20 pytest = "^7.0.0"
21 pytest-asyncio = "^0.19.0"