summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-cachecontrol_0.12.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-cachecontrol_0.12.9.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-cachecontrol_0.12.9.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-cachecontrol_0.12.9.bb b/meta-python/recipes-devtools/python/python3-cachecontrol_0.12.9.bb
new file mode 100644
index 0000000000..2b2b72d555
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-cachecontrol_0.12.9.bb
@@ -0,0 +1,29 @@
1SUMMARY = "httplib2 caching for requests"
2HOMEPAGE = "https://pypi.org/project/CacheControl/"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=12;endline=12;md5=62d6ee40749ec0b76d8a1200a1562369"
5
6# On PyPi, this is "CacheControl", rather than "cachecontrol", so we need to
7# override PYPI_PACKAGE so fetch succeeds.
8PYPI_PACKAGE = "CacheControl"
9
10SRC_URI[sha256sum] = "b5d0c98f7ee9f02e2d5a85af98b9a76c0a2c73c972c142291f823a0ed2eb7a78"
11
12inherit pypi setuptools3
13
14RDEPENDS:${PN} += "\
15 python3-crypt \
16 python3-datetime \
17 python3-email \
18 python3-lockfile \
19 python3-json \
20 python3-logging \
21 python3-msgpack \
22 python3-netclient \
23 python3-pickle \
24 python3-requests \
25 python3-urllib3 \
26 python3-mmap \
27"
28
29BBCLASSEXTEND = "native nativesdk"