summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-cmake_3.31.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-cmake_3.31.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-cmake_3.31.1.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-cmake_3.31.1.bb b/meta-python/recipes-devtools/python/python3-cmake_3.31.1.bb
new file mode 100644
index 0000000000..5e75246ecf
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-cmake_3.31.1.bb
@@ -0,0 +1,38 @@
1SUMMARY = "CMake is an open-source, cross-platform family of tools designed to build, test and package software"
2LICENSE = "BSD-3-Clause & Apache-2.0"
3LIC_FILES_CHKSUM = " \
4 file://LICENSE_BSD_3;md5=9134cb61aebbdd79dd826ccb9ae6afcd \
5 file://LICENSE_Apache_20;md5=19cbd64715b51267a47bf3750cc6a8a5 \
6"
7
8DEPENDS = "ninja-native cmake-native python3-scikit-build-native python3-scikit-build-core-native"
9
10PYPI_PACKAGE = "cmake"
11PYPI_ARCHIVE_NAME_PREFIX = "pypi-"
12
13inherit pypi python_setuptools_build_meta
14SRC_URI[sha256sum] = "45e09ef6fc5a0d3d4cac11bfee43ba3f9925f301660630d3d1e5457fbe12ecdf"
15
16SRC_URI += " \
17 file://CMakeLists.txt \
18 file://run-cmake-from-path.patch \
19"
20
21addtask do_patchbuild after do_patch before do_configure
22
23do_patchbuild () {
24 rm -f ${S}/CMakeLists.txt
25 cp ${UNPACKDIR}/CMakeLists.txt ${S}/
26}
27
28do_install:append () {
29 rm -rf ${D}${bindir}
30}
31
32RDEPENDS:${PN} = " \
33 cmake \
34 python3-scikit-build \
35 python3-scikit-build-core \
36"
37
38BBCLASSEXTEND = "native nativesdk"