summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-cmd2_2.1.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-cmd2_2.1.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-cmd2_2.1.1.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-cmd2_2.1.1.bb b/meta-python/recipes-devtools/python/python3-cmd2_2.1.1.bb
new file mode 100644
index 0000000000..e663b9c815
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-cmd2_2.1.1.bb
@@ -0,0 +1,21 @@
1SUMMARY = "Extra features for standard library's cmd module"
2HOMEPAGE = "https://github.com/python-cmd2/cmd2"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=9791cd24ca7d1807388ccd55cd066def"
5
6DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
7
8SRC_URI[sha256sum] = "a45f6a50b6081c5767b0e410da3f9cebdf6d8fb2aff80fab07d633c6eaaa6d70"
9
10inherit pypi setuptools3
11
12RDEPENDS_${PN} += "\
13 ${PYTHON_PN}-attrs \
14 ${PYTHON_PN}-colorama \
15 ${PYTHON_PN}-pyperclip \
16 ${PYTHON_PN}-wcwidth \
17 ${PYTHON_PN}-compression \
18 ${PYTHON_PN}-pydoc \
19"
20
21BBCLASSEXTEND = "native nativesdk"