summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-configargparse_1.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-configargparse_1.5.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-configargparse_1.5.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-configargparse_1.5.bb b/meta-python/recipes-devtools/python/python3-configargparse_1.5.bb
new file mode 100644
index 0000000000..4da5288815
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-configargparse_1.5.bb
@@ -0,0 +1,21 @@
1SUMMARY = "A drop-in replacement for argparse that allows options to also be set via config files and/or environment variables."
2HOMEPAGE = "https://github.com/bw2/ConfigArgParse"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=da746463714cc35999ed9a42339f2943"
5
6SRC_URI[sha256sum] = "dded3590373b7dae6ce6d0afeb4ae3def74761fdd78730952863914d4cb4bdb5"
7
8PYPI_PACKAGE = "ConfigArgParse"
9
10inherit pypi setuptools3
11
12PACKAGECONFIG ?= "yaml"
13PACKAGECONFIG[yaml] = ",,,${PYTHON_PN}-pyyaml"
14
15RDEPENDS_${PN} += "\
16 ${PYTHON_PN}-core \
17 ${PYTHON_PN}-shell \
18 ${PYTHON_PN}-json \
19"
20
21BBCLASSEXTEND = "native nativesdk"