summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-coverage_7.7.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-coverage_7.7.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-coverage_7.7.1.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-coverage_7.7.1.bb b/meta-python/recipes-devtools/python/python3-coverage_7.7.1.bb
new file mode 100644
index 0000000000..78a0ebff2f
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-coverage_7.7.1.bb
@@ -0,0 +1,22 @@
1SUMMARY = "Code coverage measurement for Python"
2HOMEPAGE = "https://coverage.readthedocs.io"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2ee41112a44fe7014dce33e26468ba93"
5
6SRC_URI[sha256sum] = "199a1272e642266b90c9f40dec7fd3d307b51bf639fa0d15980dc0b3246c1393"
7
8inherit pypi python_setuptools_build_meta
9
10RDEPENDS:${PN} += " \
11 python3-crypt \
12 python3-io \
13 python3-json \
14 python3-multiprocessing \
15 python3-pprint \
16 python3-shell \
17 python3-sqlite3 \
18 python3-tomllib \
19 python3-xml \
20"
21
22BBCLASSEXTEND = "native nativesdk"