summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-cryptography_2.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-cryptography_2.8.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-cryptography_2.8.bb61
1 files changed, 59 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-cryptography_2.8.bb b/meta-python/recipes-devtools/python/python3-cryptography_2.8.bb
index 195923343b..c75dabb974 100644
--- a/meta-python/recipes-devtools/python/python3-cryptography_2.8.bb
+++ b/meta-python/recipes-devtools/python/python3-cryptography_2.8.bb
@@ -1,8 +1,65 @@
1inherit pypi setuptools3 1SUMMARY = "Provides cryptographic recipes and primitives to python developers"
2require python-cryptography.inc 2HOMEPAGE = "https://cryptography.io/"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0 | BSD"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=097f805837700cfac572ac274cd38124"
3 6
4LDSHARED += "-pthread" 7LDSHARED += "-pthread"
5 8
9SRC_URI[md5sum] = "77730058b556c6d9838679a94c6229ce"
10SRC_URI[sha256sum] = "3cda1f0ed8747339bbdf71b9f38ca74c7b592f24f65cdb3ab3765e4b02871651"
11
6SRC_URI += " \ 12SRC_URI += " \
7 file://run-ptest \ 13 file://run-ptest \
8" 14"
15
16inherit pypi setuptools3
17
18DEPENDS += " \
19 ${PYTHON_PN}-cffi \
20 ${PYTHON_PN}-cffi-native \
21 ${PYTHON_PN}-asn1crypto \
22 ${PYTHON_PN}-six \
23"
24
25RDEPENDS_${PN} += " \
26 ${PYTHON_PN}-cffi \
27 ${PYTHON_PN}-idna \
28 ${PYTHON_PN}-asn1crypto \
29 ${PYTHON_PN}-setuptools \
30 ${PYTHON_PN}-six \
31"
32
33RDEPENDS_${PN}_class-target += " \
34 ${PYTHON_PN}-cffi \
35 ${PYTHON_PN}-idna \
36 ${PYTHON_PN}-numbers \
37 ${PYTHON_PN}-asn1crypto \
38 ${PYTHON_PN}-setuptools \
39 ${PYTHON_PN}-six \
40 ${PYTHON_PN}-threading \
41"
42
43RDEPENDS_${PN}-ptest += " \
44 ${PN} \
45 ${PYTHON_PN}-cryptography-vectors \
46 ${PYTHON_PN}-iso8601 \
47 ${PYTHON_PN}-pretend \
48 ${PYTHON_PN}-pytest \
49 ${PYTHON_PN}-pytz \
50"
51
52inherit ptest
53
54do_install_ptest() {
55 install -d ${D}${PTEST_PATH}/tests
56 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
57 install -d ${D}${PTEST_PATH}/tests/hazmat
58 cp -rf ${S}/tests/hazmat/* ${D}${PTEST_PATH}/tests/hazmat/
59}
60
61FILES_${PN}-dbg += " \
62 ${libdir}/${PYTHON_PN}2.7/site-packages/${SRCNAME}/hazmat/bindings/.debug \
63"
64
65BBCLASSEXTEND = "native nativesdk"