diff options
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-cryptography_3.1.1.bb')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-cryptography_3.1.1.bb | 66 |
1 files changed, 66 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-cryptography_3.1.1.bb b/meta-python/recipes-devtools/python/python3-cryptography_3.1.1.bb new file mode 100644 index 0000000000..1d6a9b32e0 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-cryptography_3.1.1.bb | |||
@@ -0,0 +1,66 @@ | |||
1 | SUMMARY = "Provides cryptographic recipes and primitives to python developers" | ||
2 | HOMEPAGE = "https://cryptography.io/" | ||
3 | SECTION = "devel/python" | ||
4 | LICENSE = "Apache-2.0 | BSD" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=097f805837700cfac572ac274cd38124" | ||
6 | |||
7 | LDSHARED += "-pthread" | ||
8 | |||
9 | SRC_URI[md5sum] = "c3807891d36aa9de8187e9db8b2bb457" | ||
10 | SRC_URI[sha256sum] = "9d9fc6a16357965d282dd4ab6531013935425d0dc4950df2e0cf2a1b1ac1017d" | ||
11 | |||
12 | SRC_URI += " \ | ||
13 | file://run-ptest \ | ||
14 | file://h-test.patch \ | ||
15 | " | ||
16 | |||
17 | inherit pypi setuptools3 | ||
18 | |||
19 | DEPENDS += " \ | ||
20 | ${PYTHON_PN}-cffi \ | ||
21 | ${PYTHON_PN}-cffi-native \ | ||
22 | ${PYTHON_PN}-asn1crypto \ | ||
23 | ${PYTHON_PN}-six \ | ||
24 | " | ||
25 | |||
26 | RDEPENDS_${PN} += " \ | ||
27 | ${PYTHON_PN}-cffi \ | ||
28 | ${PYTHON_PN}-idna \ | ||
29 | ${PYTHON_PN}-asn1crypto \ | ||
30 | ${PYTHON_PN}-setuptools \ | ||
31 | ${PYTHON_PN}-six \ | ||
32 | " | ||
33 | |||
34 | RDEPENDS_${PN}_class-target += " \ | ||
35 | ${PYTHON_PN}-cffi \ | ||
36 | ${PYTHON_PN}-idna \ | ||
37 | ${PYTHON_PN}-numbers \ | ||
38 | ${PYTHON_PN}-asn1crypto \ | ||
39 | ${PYTHON_PN}-setuptools \ | ||
40 | ${PYTHON_PN}-six \ | ||
41 | ${PYTHON_PN}-threading \ | ||
42 | " | ||
43 | |||
44 | RDEPENDS_${PN}-ptest += " \ | ||
45 | ${PN} \ | ||
46 | ${PYTHON_PN}-cryptography-vectors \ | ||
47 | ${PYTHON_PN}-iso8601 \ | ||
48 | ${PYTHON_PN}-pretend \ | ||
49 | ${PYTHON_PN}-pytest \ | ||
50 | ${PYTHON_PN}-pytz \ | ||
51 | " | ||
52 | |||
53 | inherit ptest | ||
54 | |||
55 | do_install_ptest() { | ||
56 | install -d ${D}${PTEST_PATH}/tests | ||
57 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | ||
58 | install -d ${D}${PTEST_PATH}/tests/hazmat | ||
59 | cp -rf ${S}/tests/hazmat/* ${D}${PTEST_PATH}/tests/hazmat/ | ||
60 | } | ||
61 | |||
62 | FILES_${PN}-dbg += " \ | ||
63 | ${libdir}/${PYTHON_PN}2.7/site-packages/${SRCNAME}/hazmat/bindings/.debug \ | ||
64 | " | ||
65 | |||
66 | BBCLASSEXTEND = "native nativesdk" | ||