summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-dirty-equals_0.9.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-dirty-equals_0.9.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-dirty-equals_0.9.0.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-dirty-equals_0.9.0.bb b/meta-python/recipes-devtools/python/python3-dirty-equals_0.9.0.bb
new file mode 100644
index 0000000000..f944d75e97
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-dirty-equals_0.9.0.bb
@@ -0,0 +1,27 @@
1SUMMARY = "Doing dirty (but extremely useful) things with equals."
2DESCRIPTION = "dirty-equals is a python library that (mis)uses the \
3__eq__ method to make python code (generally unit tests) more \
4declarative and therefore easier to read and write.\
5\
6dirty-equals can be used in whatever context you like, but it comes \
7into its own when writing unit tests for applications where you're \
8commonly checking the response to API calls and the contents of a database."
9HOMEPAGE = "https://github.com/samuelcolvin/dirty-equals"
10LICENSE = "MIT"
11LIC_FILES_CHKSUM = "file://LICENSE;md5=ab599c188b4a314d2856b3a55030c75c"
12
13SRC_URI[sha256sum] = "17f515970b04ed7900b733c95fd8091f4f85e52f1fb5f268757f25c858eb1f7b"
14
15S = "${WORKDIR}/dirty_equals-${PV}"
16
17inherit pypi python_hatchling
18
19PYPI_PACKAGE = "dirty_equals"
20UPSTREAM_CHECK_PYPI_PACKAGE = "${PYPI_PACKAGE}"
21
22RDEPENDS:${PN} += " \
23 python3-pytz \
24 python3-core \
25 python3-json \
26 python3-netclient \
27"