summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-dnspython_2.0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-dnspython_2.0.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-dnspython_2.0.0.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-dnspython_2.0.0.bb b/meta-python/recipes-devtools/python/python3-dnspython_2.0.0.bb
new file mode 100644
index 0000000000..a4e9846191
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-dnspython_2.0.0.bb
@@ -0,0 +1,33 @@
1DESCRIPTION = "DNS toolkit for Python"
2HOMEPAGE = "http://www.dnspython.org/"
3LICENSE = "ISC"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=5af50906b5929837f667dfe31052bd34"
5
6SRC_URI[md5sum] = "42f922c9223dde0275e8c0695ead37da"
7SRC_URI[sha256sum] = "044af09374469c3a39eeea1a146e8cac27daec951f1f1f157b1962fc7cb9d1b7"
8
9PYPI_PACKAGE_EXT = "zip"
10
11inherit pypi setuptools3 ptest
12
13SRC_URI += " \
14 file://run-ptest \
15"
16
17RDEPENDS_${PN}-ptest += " \
18 ${PYTHON_PN}-pytest \
19"
20
21do_install_ptest() {
22 install -d ${D}${PTEST_PATH}/tests
23 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
24}
25
26RDEPENDS_${PN} += " \
27 ${PYTHON_PN}-crypt \
28 ${PYTHON_PN}-io \
29 ${PYTHON_PN}-math \
30 ${PYTHON_PN}-netclient \
31 ${PYTHON_PN}-numbers \
32 ${PYTHON_PN}-threading \
33"