summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-dynamic-dispatch_1.0.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-dynamic-dispatch_1.0.3.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-dynamic-dispatch_1.0.3.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-dynamic-dispatch_1.0.3.bb b/meta-python/recipes-devtools/python/python3-dynamic-dispatch_1.0.3.bb
new file mode 100644
index 0000000000..2bf487584a
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-dynamic-dispatch_1.0.3.bb
@@ -0,0 +1,19 @@
1SUMMARY = "dynamic dispatch decorator for classes and functions"
2HOMEPAGE = "https://github.com/XevoInc/dynamic_dispatch"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=ea70b07c354e36056bd35e17c9c3face"
5
6inherit pypi setuptools3
7
8SRC_URI[md5sum] = "6bd3cc24427de753eed0656e89d5302c"
9SRC_URI[sha256sum] = "fbc676aaedc8ec542056c21e5e206b8b62b8d11c3f3c5cfb32b273936da89604"
10
11PYPI_PACKAGE = "dynamic_dispatch"
12
13DEPENDS += "python3-setuptools-scm-native"
14RDEPENDS_${PN} += "\
15 python3-typing \
16 python3-typeguard \
17"
18
19BBCLASSEXTEND = "native nativesdk"