summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-elementpath_4.1.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-elementpath_4.1.4.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-elementpath_4.1.4.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-elementpath_4.1.4.bb b/meta-python/recipes-devtools/python/python3-elementpath_4.1.4.bb
new file mode 100644
index 0000000000..60c54f0193
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-elementpath_4.1.4.bb
@@ -0,0 +1,19 @@
1DESCRIPTION = "Provide XPath 1.0 and 2.0 selectors for Python's ElementTree XML data structures, both for the standard ElementTree library and for the lxml.etree library."
2HOMEPAGE = "https://github.com/sissaschool/elementpath"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=5dbb7fb7d72da3921202dd7b995d3ecf"
5
6SRC_URI[sha256sum] = "f991c42ff66fa06e219141ccf65890261e6635b448e7d4c2d8b62dc5bf1de9e8"
7
8PYPI_PACKAGE = "elementpath"
9inherit pypi setuptools3
10
11RDEPENDS:${PN} += " \
12 ${PYTHON_PN}-xml \
13 ${PYTHON_PN}-core \
14 ${PYTHON_PN}-numbers \
15 ${PYTHON_PN}-datetime \
16 ${PYTHON_PN}-stringold \
17"
18
19BBCLASSEXTEND = "native nativesdk"