summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-evdev_1.4.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-evdev_1.4.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-evdev_1.4.0.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-evdev_1.4.0.bb b/meta-python/recipes-devtools/python/python3-evdev_1.4.0.bb
new file mode 100644
index 0000000000..e15d83b60e
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-evdev_1.4.0.bb
@@ -0,0 +1,22 @@
1SUMMARY = "Python evdev lib"
2HOMEPAGE = "https://github.com/gvalkov/python-evdev"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=18debddbb3f52c661a129724a883a8e2"
5
6SRC_URI[sha256sum] = "8782740eb1a86b187334c07feb5127d3faa0b236e113206dfe3ae8f77fb1aaf1"
7
8inherit pypi setuptools3
9
10do_compile_prepend() {
11 rm -rf ${S}/evdev/ecodes.c
12}
13
14DISTUTILS_BUILD_ARGS = "build_ecodes --evdev-headers ${STAGING_DIR_TARGET}/usr/include/linux/input.h:${STAGING_DIR_TARGET}/usr/include/linux/input-event-codes.h"
15
16RDEPENDS_${PN} += "\
17 ${PYTHON_PN}-ctypes \
18 ${PYTHON_PN}-fcntl \
19 ${PYTHON_PN}-io \
20 ${PYTHON_PN}-shell \
21 ${PYTHON_PN}-stringold \
22 "