summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-evdev_1.8.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-evdev_1.8.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-evdev_1.8.0.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-evdev_1.8.0.bb b/meta-python/recipes-devtools/python/python3-evdev_1.8.0.bb
new file mode 100644
index 0000000000..1a382f49dd
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-evdev_1.8.0.bb
@@ -0,0 +1,22 @@
1SUMMARY = "Python evdev lib"
2HOMEPAGE = "https://github.com/gvalkov/python-evdev"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=d7bd1cc4c71b706c7e2d4053aef50f2a"
5
6SRC_URI[sha256sum] = "45598eee1ae3876a3122ca1dc0ec8049c01931672d12478b5c610afc24e47d75"
7
8inherit pypi python_setuptools_build_meta
9
10do_compile:prepend() {
11 rm -rf ${S}/evdev/ecodes.c
12}
13
14SETUPTOOLS_BUILD_ARGS = "build_ecodes --evdev-headers ${STAGING_DIR_TARGET}/usr/include/linux/input.h:${STAGING_DIR_TARGET}/usr/include/linux/input-event-codes.h"
15
16RDEPENDS:${PN} += "\
17 python3-ctypes \
18 python3-fcntl \
19 python3-io \
20 python3-shell \
21 python3-stringold \
22 "