summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-execnet_1.9.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-execnet_1.9.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-execnet_1.9.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-execnet_1.9.0.bb b/meta-python/recipes-devtools/python/python3-execnet_1.9.0.bb
new file mode 100644
index 0000000000..ec16e8884e
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-execnet_1.9.0.bb
@@ -0,0 +1,19 @@
1# Copyright (C) 2021 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "execnet: rapid multi-Python deployment"
5HOMEPAGE = "https://execnet.readthedocs.io/en/latest/"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=772fcdaca14b378878d05c7d857e6c3e"
8
9SRC_URI[sha256sum] = "8f694f3ba9cc92cab508b152dcfe322153975c29bda272e2fd7f3f00f36e47c5"
10
11DEPENDS += "python3-pip-native"
12
13inherit pypi setuptools3
14
15PACKAGECONFIG[testing] = ",,,python3-pre-commit"
16
17RDEPENDS_${PN} += "python3-core python3-crypt python3-ctypes python3-fcntl python3-io python3-shell python3-threading"
18
19BBCLASSEXTEND = "native nativesdk"