summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-flask_3.1.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-flask_3.1.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-flask_3.1.1.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-flask_3.1.1.bb b/meta-python/recipes-devtools/python/python3-flask_3.1.1.bb
new file mode 100644
index 0000000000..a1bea8e69b
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-flask_3.1.1.bb
@@ -0,0 +1,26 @@
1SUMMARY = "A microframework based on Werkzeug, Jinja2 and good intentions"
2DESCRIPTION = "\
3Flask is a microframework for Python based on Werkzeug, Jinja 2 and good \
4intentions. And before you ask: It’s BSD licensed!"
5HOMEPAGE = "https://github.com/pallets/flask"
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=ffeffa59c90c9c4a033c7574f8f3fb75"
8
9SRC_URI[sha256sum] = "284c7b8f2f58cb737f0cf1c30fd7eaf0ccfcde196099d24ecede3fc2005aa59e"
10
11inherit pypi python_setuptools_build_meta ptest-python-pytest
12
13CLEANBROKEN = "1"
14
15RDEPENDS:${PN} = " \
16 python3-blinker \
17 python3-click \
18 python3-importlib-metadata \
19 python3-itsdangerous \
20 python3-jinja2 \
21 python3-werkzeug \
22"
23
24RDEPENDS:${PN}-ptest += "\
25 python3-asgiref \
26"