summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-gcovr_8.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-gcovr_8.3.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-gcovr_8.3.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-gcovr_8.3.bb b/meta-python/recipes-devtools/python/python3-gcovr_8.3.bb
new file mode 100644
index 0000000000..a9b29a4458
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-gcovr_8.3.bb
@@ -0,0 +1,32 @@
1DESCRIPTION = "generate GCC code coverage reports"
2HOMEPAGE = "https://gcovr.com"
3SECTION = "devel/python"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=ae27363fce24765bc79a095313a3b002"
6
7SRC_URI = " \
8 git://github.com/gcovr/gcovr.git;branch=main;protocol=https \
9 file://0001-pyproject.toml-Support-newer-versions.patch \
10"
11SRCREV = "fe536afac4da31e86909191ef31708755ab8cf83"
12
13S = "${WORKDIR}/git"
14
15inherit python_hatchling
16
17DEPENDS += " \
18 python3-hatchling-native \
19 python3-hatch-vcs-native \
20 python3-hatch-fancy-pypi-readme-native \
21"
22
23RDEPENDS:${PN} += " \
24 python3-colorlog \
25 python3-jinja2 \
26 python3-lxml \
27 python3-multiprocessing \
28 python3-pygments \
29 python3-setuptools \
30"
31
32BBCLASSEXTEND = "native nativesdk"