diff options
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-grpcio-tools/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-grpcio-tools/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch | 13 |
1 files changed, 8 insertions, 5 deletions
diff --git a/meta-python/recipes-devtools/python/python3-grpcio-tools/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch b/meta-python/recipes-devtools/python/python3-grpcio-tools/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch index 5366a1e1cf..439b337bda 100644 --- a/meta-python/recipes-devtools/python/python3-grpcio-tools/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch +++ b/meta-python/recipes-devtools/python/python3-grpcio-tools/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch | |||
@@ -27,7 +27,7 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com> | |||
27 | 1 file changed, 6 insertions(+), 4 deletions(-) | 27 | 1 file changed, 6 insertions(+), 4 deletions(-) |
28 | 28 | ||
29 | diff --git a/setup.py b/setup.py | 29 | diff --git a/setup.py b/setup.py |
30 | index 5e19b63..61b30d8 100644 | 30 | index 1a997df..86e3ad1 100644 |
31 | --- a/setup.py | 31 | --- a/setup.py |
32 | +++ b/setup.py | 32 | +++ b/setup.py |
33 | @@ -90,9 +90,11 @@ def check_linker_need_libatomic(): | 33 | @@ -90,9 +90,11 @@ def check_linker_need_libatomic(): |
@@ -36,12 +36,12 @@ index 5e19b63..61b30d8 100644 | |||
36 | ) | 36 | ) |
37 | - cxx = os.environ.get("CXX", "c++") | 37 | - cxx = os.environ.get("CXX", "c++") |
38 | - cpp_test = subprocess.Popen( | 38 | - cpp_test = subprocess.Popen( |
39 | - [cxx, "-x", "c++", "-std=c++14", "-"], | 39 | - [cxx, "-x", "c++", "-std=c++17", "-"], |
40 | + cxx, cxx_args = os.environ.get('CXX').split(' ', 1) or 'c++' | 40 | + cxx, cxx_args = os.environ.get('CXX').split(' ', 1) or 'c++' |
41 | + if not cxx_args: | 41 | + if not cxx_args: |
42 | + cxx_args = "-g" | 42 | + cxx_args = "-g" |
43 | + | 43 | + |
44 | + cpp_test = subprocess.Popen([cxx, cxx_args, '-x', 'c++', '-std=c++14', '-'], | 44 | + cpp_test = subprocess.Popen([cxx, cxx_args, '-x', 'c++', '-std=c++17', '-'], |
45 | stdin=PIPE, | 45 | stdin=PIPE, |
46 | stdout=PIPE, | 46 | stdout=PIPE, |
47 | stderr=PIPE, | 47 | stderr=PIPE, |
@@ -49,8 +49,11 @@ index 5e19b63..61b30d8 100644 | |||
49 | # Double-check to see if -latomic actually can solve the problem. | 49 | # Double-check to see if -latomic actually can solve the problem. |
50 | # https://github.com/grpc/grpc/issues/22491 | 50 | # https://github.com/grpc/grpc/issues/22491 |
51 | cpp_test = subprocess.Popen( | 51 | cpp_test = subprocess.Popen( |
52 | - [cxx, "-x", "c++", "-std=c++14", "-", "-latomic"], | 52 | - [cxx, "-x", "c++", "-std=c++17", "-", "-latomic"], |
53 | + [cxx, cxx_args, '-x', 'c++', '-std=c++14', '-', '-latomic'], | 53 | + [cxx, cxx_args, '-x', 'c++', '-std=c++17', '-', '-latomic'], |
54 | stdin=PIPE, | 54 | stdin=PIPE, |
55 | stdout=PIPE, | 55 | stdout=PIPE, |
56 | stderr=PIPE, | 56 | stderr=PIPE, |
57 | -- | ||
58 | 2.43.0 | ||
59 | |||