diff options
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch | 64 |
1 files changed, 64 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch b/meta-python/recipes-devtools/python/python3-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch new file mode 100644 index 0000000000..131daace06 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch | |||
@@ -0,0 +1,64 @@ | |||
1 | From b02be74a2eff8abc612ef84f30e0fbce6a7f65f5 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Fri, 4 Aug 2017 09:04:07 -0700 | ||
4 | Subject: [PATCH] setup.py: Do not mix C and C++ compiler options | ||
5 | |||
6 | EXTRA_ENV_COMPILE_ARGS is used both with CC and CXX | ||
7 | so using -std=c++11 or -std=gnu99 together will cause | ||
8 | build time errors espcially with clang | ||
9 | |||
10 | error: invalid argument '-std=gnu99' not allowed with 'C++' | ||
11 | |||
12 | gcc7 ( defaults are -std=gnu11 and -std=gnu++14 ) | ||
13 | as well clang default to these standards mode or newer | ||
14 | anyway | ||
15 | |||
16 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
17 | --- | ||
18 | setup.py | 2 +- | ||
19 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
20 | |||
21 | --- a/setup.py | ||
22 | +++ b/setup.py | ||
23 | @@ -144,9 +144,10 @@ ENABLE_DOCUMENTATION_BUILD = os.environ. | ||
24 | |||
25 | def check_linker_need_libatomic(): | ||
26 | """Test if linker on system needs libatomic.""" | ||
27 | + compiler, cc_args = os.environ.get('CC').split(' ', 1) or 'cc' | ||
28 | code_test = (b'#include <atomic>\n' + | ||
29 | b'int main() { return std::atomic<int64_t>{}; }') | ||
30 | - cc_test = subprocess.Popen(['cc', '-x', 'c++', '-std=c++11', '-'], | ||
31 | + cc_test = subprocess.Popen([compiler, cc_args, '-x', 'c++', '-std=c++11', '-'], | ||
32 | stdin=PIPE, | ||
33 | stdout=PIPE, | ||
34 | stderr=PIPE) | ||
35 | @@ -163,7 +164,7 @@ def check_linker_need_libatomic(): | ||
36 | EXTRA_ENV_COMPILE_ARGS = os.environ.get('GRPC_PYTHON_CFLAGS', None) | ||
37 | EXTRA_ENV_LINK_ARGS = os.environ.get('GRPC_PYTHON_LDFLAGS', None) | ||
38 | if EXTRA_ENV_COMPILE_ARGS is None: | ||
39 | - EXTRA_ENV_COMPILE_ARGS = ' -std=c++11' | ||
40 | + EXTRA_ENV_COMPILE_ARGS = ' ' | ||
41 | if 'win32' in sys.platform: | ||
42 | if sys.version_info < (3, 5): | ||
43 | EXTRA_ENV_COMPILE_ARGS += ' -D_hypot=hypot' | ||
44 | @@ -180,7 +181,7 @@ if EXTRA_ENV_COMPILE_ARGS is None: | ||
45 | # available dynamically | ||
46 | EXTRA_ENV_COMPILE_ARGS += ' /MT' | ||
47 | elif "linux" in sys.platform: | ||
48 | - EXTRA_ENV_COMPILE_ARGS += ' -std=gnu99 -fvisibility=hidden -fno-wrapv -fno-exceptions' | ||
49 | + EXTRA_ENV_COMPILE_ARGS += ' -fvisibility=hidden -fno-wrapv -fno-exceptions' | ||
50 | elif "darwin" in sys.platform: | ||
51 | EXTRA_ENV_COMPILE_ARGS += ' -stdlib=libc++ -fvisibility=hidden -fno-wrapv -fno-exceptions' | ||
52 | |||
53 | --- a/src/python/grpcio/commands.py | ||
54 | +++ b/src/python/grpcio/commands.py | ||
55 | @@ -216,7 +216,8 @@ class BuildExt(build_ext.build_ext): | ||
56 | when invoked in C mode. GCC is okay with this, while clang is not. | ||
57 | """ | ||
58 | # TODO(lidiz) Remove the generated a.out for success tests. | ||
59 | - cc_test = subprocess.Popen(['cc', '-x', 'c', '-std=c++11', '-'], | ||
60 | + compiler, cc_args = os.environ.get('CC').split(' ', 1) or 'cc' | ||
61 | + cc_test = subprocess.Popen([compiler, cc_args, '-x', 'c', '-std=c++11', '-'], | ||
62 | stdin=subprocess.PIPE, | ||
63 | stdout=subprocess.PIPE, | ||
64 | stderr=subprocess.PIPE) | ||