diff options
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-grpcio_1.35.0.bb')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-grpcio_1.35.0.bb | 43 |
1 files changed, 43 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-grpcio_1.35.0.bb b/meta-python/recipes-devtools/python/python3-grpcio_1.35.0.bb new file mode 100644 index 0000000000..2c137f6ce7 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-grpcio_1.35.0.bb | |||
@@ -0,0 +1,43 @@ | |||
1 | DESCRIPTION = "Google gRPC" | ||
2 | HOMEPAGE = "http://www.grpc.io/" | ||
3 | SECTION = "devel/python" | ||
4 | LICENSE = "Apache-2.0" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" | ||
6 | |||
7 | DEPENDS += "${PYTHON_PN}-protobuf" | ||
8 | |||
9 | SRC_URI += "file://0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch" | ||
10 | SRC_URI_append_class-target = " file://ppc-boringssl-support.patch \ | ||
11 | file://riscv64_support.patch \ | ||
12 | file://boring_ssl.patch \ | ||
13 | " | ||
14 | SRC_URI[sha256sum] = "7bd0ebbb14dde78bf66a1162efd29d3393e4e943952e2f339757aa48a184645c" | ||
15 | |||
16 | RDEPENDS_${PN} = "${PYTHON_PN}-protobuf \ | ||
17 | ${PYTHON_PN}-setuptools \ | ||
18 | ${PYTHON_PN}-six \ | ||
19 | " | ||
20 | |||
21 | inherit setuptools3 | ||
22 | inherit pypi | ||
23 | |||
24 | export GRPC_PYTHON_DISABLE_LIBC_COMPATIBILITY = "1" | ||
25 | |||
26 | BORING_SSL_PLATFORM_arm = "linux-arm" | ||
27 | BORING_SSL_PLATFORM_x86-64 = "linux-x86_64" | ||
28 | BORING_SSL_PLATFORM ?= "unsupported" | ||
29 | export GRPC_BORING_SSL_PLATFORM = "${BORING_SSL_PLATFORM}" | ||
30 | |||
31 | BORING_SSL_x86-64 = "1" | ||
32 | BORING_SSL_arm = "1" | ||
33 | BORING_SSL ?= "0" | ||
34 | export GRPC_BUILD_WITH_BORING_SSL_ASM = "${BORING_SSL}" | ||
35 | |||
36 | GRPC_CFLAGS_append_toolchain-clang = " -fvisibility=hidden -fno-wrapv -fno-exceptions" | ||
37 | export GRPC_PYTHON_CFLAGS = "${GRPC_CFLAGS}" | ||
38 | |||
39 | CLEANBROKEN = "1" | ||
40 | |||
41 | BBCLASSEXTEND = "native nativesdk" | ||
42 | |||
43 | CCACHE_DISABLE = "1" | ||