diff options
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-grpcio_1.56.0.bb')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-grpcio_1.56.0.bb | 51 |
1 files changed, 51 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-grpcio_1.56.0.bb b/meta-python/recipes-devtools/python/python3-grpcio_1.56.0.bb new file mode 100644 index 0000000000..33c13b0a01 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-grpcio_1.56.0.bb | |||
@@ -0,0 +1,51 @@ | |||
1 | DESCRIPTION = "Google gRPC" | ||
2 | HOMEPAGE = "http://www.grpc.io/" | ||
3 | SECTION = "devel/python" | ||
4 | LICENSE = "Apache-2.0 & BSD-3-Clause" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=731e401b36f8077ae0c134b59be5c906" | ||
6 | |||
7 | DEPENDS += "${PYTHON_PN}-protobuf" | ||
8 | |||
9 | SRC_URI += "file://0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch" | ||
10 | SRC_URI:append:class-target = " file://ppc-boringssl-support.patch \ | ||
11 | file://mips_bigendian.patch \ | ||
12 | file://0001-Include-missing-cstdint-header.patch \ | ||
13 | file://abseil-ppc-fixes.patch;patchdir=third_party/abseil-cpp \ | ||
14 | file://0001-zlib-Include-unistd.h-for-open-close-C-APIs.patch \ | ||
15 | " | ||
16 | SRC_URI[sha256sum] = "4c08ee21b3d10315b8dc26f6c13917b20ed574cdbed2d2d80c53d5508fdcc0f2" | ||
17 | |||
18 | RDEPENDS:${PN} = "${PYTHON_PN}-protobuf \ | ||
19 | ${PYTHON_PN}-setuptools \ | ||
20 | ${PYTHON_PN}-six \ | ||
21 | " | ||
22 | |||
23 | inherit setuptools3 | ||
24 | inherit pypi | ||
25 | |||
26 | CFLAGS:append:libc-musl = " -D_LARGEFILE64_SOURCE" | ||
27 | |||
28 | export GRPC_PYTHON_DISABLE_LIBC_COMPATIBILITY = "1" | ||
29 | |||
30 | BORING_SSL_PLATFORM:arm = "linux-arm" | ||
31 | BORING_SSL_PLATFORM:x86-64 = "linux-x86_64" | ||
32 | BORING_SSL_PLATFORM:aarch64 = "linux-aarch64" | ||
33 | BORING_SSL_PLATFORM ?= "unsupported" | ||
34 | export GRPC_BORING_SSL_PLATFORM = "${BORING_SSL_PLATFORM}" | ||
35 | export GRPC_BUILD_OVERRIDE_BORING_SSL_ASM_PLATFORM = "${BORING_SSL_PLATFORM}" | ||
36 | |||
37 | BORING_SSL:arm = "1" | ||
38 | BORING_SSL:x86-64 = "1" | ||
39 | BORING_SSL:aarch64 = "1" | ||
40 | BORING_SSL ?= "0" | ||
41 | export GRPC_BUILD_WITH_BORING_SSL_ASM = "${BORING_SSL}" | ||
42 | |||
43 | GRPC_CFLAGS ?= "" | ||
44 | GRPC_CFLAGS:append:toolchain-clang = " -fvisibility=hidden -fno-wrapv -fno-exceptions" | ||
45 | export GRPC_PYTHON_CFLAGS = "${GRPC_CFLAGS}" | ||
46 | |||
47 | CLEANBROKEN = "1" | ||
48 | |||
49 | BBCLASSEXTEND = "native nativesdk" | ||
50 | |||
51 | CCACHE_DISABLE = "1" | ||