diff options
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-grpcio_1.62.0.bb')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-grpcio_1.62.0.bb | 48 |
1 files changed, 48 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-grpcio_1.62.0.bb b/meta-python/recipes-devtools/python/python3-grpcio_1.62.0.bb new file mode 100644 index 0000000000..ceb22f0e29 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-grpcio_1.62.0.bb | |||
@@ -0,0 +1,48 @@ | |||
1 | DESCRIPTION = "Google gRPC" | ||
2 | HOMEPAGE = "http://www.grpc.io/" | ||
3 | SECTION = "devel/python" | ||
4 | LICENSE = "Apache-2.0 & BSD-3-Clause" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=731e401b36f8077ae0c134b59be5c906" | ||
6 | |||
7 | DEPENDS += "python3-protobuf" | ||
8 | |||
9 | SRC_URI += "file://0001-Include-missing-cstdint-header.patch \ | ||
10 | file://abseil-ppc-fixes.patch \ | ||
11 | file://0001-zlib-Include-unistd.h-for-open-close-C-APIs.patch \ | ||
12 | " | ||
13 | SRC_URI[sha256sum] = "748496af9238ac78dcd98cce65421f1adce28c3979393e3609683fcd7f3880d7" | ||
14 | |||
15 | RDEPENDS:${PN} = "python3-protobuf \ | ||
16 | python3-setuptools \ | ||
17 | python3-six \ | ||
18 | " | ||
19 | |||
20 | inherit setuptools3 | ||
21 | inherit pypi | ||
22 | |||
23 | CFLAGS:append:libc-musl = " -D_LARGEFILE64_SOURCE" | ||
24 | |||
25 | export GRPC_PYTHON_DISABLE_LIBC_COMPATIBILITY = "1" | ||
26 | |||
27 | BORING_SSL_PLATFORM:arm = "linux-arm" | ||
28 | BORING_SSL_PLATFORM:x86-64 = "linux-x86_64" | ||
29 | BORING_SSL_PLATFORM:aarch64 = "linux-aarch64" | ||
30 | BORING_SSL_PLATFORM ?= "unsupported" | ||
31 | export GRPC_BORING_SSL_PLATFORM = "${BORING_SSL_PLATFORM}" | ||
32 | export GRPC_BUILD_OVERRIDE_BORING_SSL_ASM_PLATFORM = "${BORING_SSL_PLATFORM}" | ||
33 | |||
34 | BORING_SSL:arm = "1" | ||
35 | BORING_SSL:x86-64 = "1" | ||
36 | BORING_SSL:aarch64 = "1" | ||
37 | BORING_SSL ?= "0" | ||
38 | export GRPC_BUILD_WITH_BORING_SSL_ASM = "${BORING_SSL}" | ||
39 | |||
40 | GRPC_CFLAGS ?= "" | ||
41 | GRPC_CFLAGS:append:toolchain-clang = " -fvisibility=hidden -fno-wrapv -fno-exceptions" | ||
42 | export GRPC_PYTHON_CFLAGS = "${GRPC_CFLAGS}" | ||
43 | |||
44 | CLEANBROKEN = "1" | ||
45 | |||
46 | BBCLASSEXTEND = "native nativesdk" | ||
47 | |||
48 | CCACHE_DISABLE = "1" | ||