summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-inline-snapshot_0.23.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-inline-snapshot_0.23.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-inline-snapshot_0.23.0.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-inline-snapshot_0.23.0.bb b/meta-python/recipes-devtools/python/python3-inline-snapshot_0.23.0.bb
new file mode 100644
index 0000000000..0442f74f92
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-inline-snapshot_0.23.0.bb
@@ -0,0 +1,21 @@
1SUMMARY = "golden master/snapshot/approval testing library which puts the values right into your source code"
2HOMEPAGE = "https://15r10nk.github.io/inline-snapshot"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=7a35eb90dfdf03953dd2074d0fdba1d4"
5
6DEPENDS = "python3-hatchling-native"
7SRC_URI[sha256sum] = "872d027b1eae4e3e3b4028e0d46128bafbf62889a2424a2667dbe4b69cb1ffdf"
8
9inherit pypi python_hatchling
10
11PYPI_PACKAGE = "inline_snapshot"
12UPSTREAM_CHECK_PYPI_PACKAGE = "${PYPI_PACKAGE}"
13
14RDEPENDS:${PN} = "python3-asttokens \
15 python3-black \
16 python3-click \
17 python3-executing \
18 python3-rich \
19 python3-tomli \
20 python3-typing-extensions \
21 "