summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-ipython_8.30.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-ipython_8.30.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-ipython_8.30.0.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-ipython_8.30.0.bb b/meta-python/recipes-devtools/python/python3-ipython_8.30.0.bb
new file mode 100644
index 0000000000..41aa0dadf7
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-ipython_8.30.0.bb
@@ -0,0 +1,26 @@
1SUMMARY = "IPython: Productive Interactive Computing"
2HOMEPAGE = "https://ipython.org"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://COPYING.rst;md5=59b20262b8663cdd094005bddf47af5f"
5
6SRC_URI[sha256sum] = "cb0a405a306d2995a5cbb9901894d240784a9f341394c6ba3f4fe8c6eb89ff6e"
7
8RDEPENDS:${PN} = "\
9 python3-setuptools \
10 python3-jedi \
11 python3-decorator \
12 python3-pickleshare \
13 python3-traitlets \
14 python3-prompt-toolkit \
15 python3-pygments \
16 python3-backcall \
17 python3-pydoc \
18 python3-debugger \
19 python3-pexpect \
20 python3-unixadmin \
21 python3-misc \
22 python3-sqlite3 \
23 python3-stack-data \
24"
25
26inherit python_setuptools_build_meta pypi