summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-jsonrpcserver_4.2.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-jsonrpcserver_4.2.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-jsonrpcserver_4.2.0.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-jsonrpcserver_4.2.0.bb b/meta-python/recipes-devtools/python/python3-jsonrpcserver_4.2.0.bb
new file mode 100644
index 0000000000..53f01f622e
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-jsonrpcserver_4.2.0.bb
@@ -0,0 +1,22 @@
1SUMMARY = "Library to process JSON-RPC requests"
2HOMEPAGE = "https://github.com/bcb/jsonrpcserver"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=c89120516900f96f4c60d35fdc4c3f15"
5
6SRC_URI[sha256sum] = "0c9e5b9445621138521e912016ae39b3badadd2607140dcbb0c8062934ab4854"
7
8inherit pypi setuptools3
9
10RDEPENDS_${PN} += "\
11 python3-apply-defaults \
12 python3-asyncio \
13 python3-core \
14 python3-json \
15 python3-jsonschema \
16 python3-logging \
17 python3-netclient \
18 python3-pkgutil \
19"
20
21BBCLASSEXTEND = "native nativesdk"
22