summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-langtable_0.0.57.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-langtable_0.0.57.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-langtable_0.0.57.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-langtable_0.0.57.bb b/meta-python/recipes-devtools/python/python3-langtable_0.0.57.bb
new file mode 100644
index 0000000000..39819f4351
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-langtable_0.0.57.bb
@@ -0,0 +1,23 @@
1DESCRIPTION = "langtable is used to guess reasonable defaults for locale,\
2keyboard, territory"
3HOMEPAGE = "https://github.com/mike-fabian/langtable/"
4LICENSE = "GPLv3+"
5SECTION = "devel/python"
6
7LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
8
9SRC_URI[sha256sum] = "6c3c0a6577652c81871cbaf139046e1c88ead8439c585bd83976b3092f57e9d7"
10
11inherit pypi setuptools3 python3native
12
13DISTUTILS_INSTALL_ARGS += " \
14 --install-data=${datadir}/langtable"
15
16FILES:${PN} += "${datadir}/*"
17
18RDEPENDS:${PN} += " \
19 ${PYTHON_PN}-compression \
20 ${PYTHON_PN}-doctest \
21 ${PYTHON_PN}-logging \
22 ${PYTHON_PN}-xml \
23"