diff options
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-lrparsing')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-lrparsing/0001-setup.py-use-setuptools-instead-of-distutils.patch | 27 |
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-lrparsing/0001-setup.py-use-setuptools-instead-of-distutils.patch b/meta-python/recipes-devtools/python/python3-lrparsing/0001-setup.py-use-setuptools-instead-of-distutils.patch new file mode 100644 index 0000000000..28af8fa4ec --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-lrparsing/0001-setup.py-use-setuptools-instead-of-distutils.patch | |||
@@ -0,0 +1,27 @@ | |||
1 | From 04d9a4cea699d64b464daef7760de594b1c7f9bf Mon Sep 17 00:00:00 2001 | ||
2 | From: Justin Bronder <jsbronder@cold-front.org> | ||
3 | Date: Tue, 1 Mar 2022 17:34:34 -0500 | ||
4 | Subject: [PATCH] setup.py: use setuptools instead of distutils | ||
5 | |||
6 | With python 3.10, distutils is deprecated in favor of setuptools and will | ||
7 | be removed in python 3.12. | ||
8 | |||
9 | Upstream-Status: Submitted [sent to maintainer at russell-lrparsing@stuart.id.au] | ||
10 | Signed-off-by: Justin Bronder <jsbronder@cold-front.org> | ||
11 | --- | ||
12 | setup.py | 2 +- | ||
13 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
14 | |||
15 | diff --git a/setup.py b/setup.py | ||
16 | index 89ea344..2848b4f 100644 | ||
17 | --- a/setup.py | ||
18 | +++ b/setup.py | ||
19 | @@ -3,7 +3,7 @@ | ||
20 | # Copyright (c) 2013,2014,2015,2016,2017,2018,2021 Russell Stuart. | ||
21 | # Licensed under GPLv2, or any later version. | ||
22 | # | ||
23 | -from distutils.core import setup | ||
24 | +from setuptools import setup | ||
25 | import re | ||
26 | |||
27 | def get_long_description(): | ||