summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-lxml_4.6.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-lxml_4.6.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-lxml_4.6.2.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-lxml_4.6.2.bb b/meta-python/recipes-devtools/python/python3-lxml_4.6.2.bb
new file mode 100644
index 0000000000..f7aed6d771
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-lxml_4.6.2.bb
@@ -0,0 +1,41 @@
1SUMMARY = "Powerful and Pythonic XML processing library combining libxml2/libxslt with the ElementTree API."
2DESCRIPTION = "lxml is a Pythonic, mature binding for the libxml2 and \
3libxslt libraries. It provides safe and convenient access to these \
4libraries using the ElementTree API. It extends the ElementTree API \
5significantly to offer support for XPath, RelaxNG, XML Schema, XSLT, \
6C14N and much more."
7HOMEPAGE = "http://codespeak.net/lxml"
8SECTION = "devel/python"
9LICENSE = "BSD & GPLv2 & MIT & PSF"
10LIC_FILES_CHKSUM = "file://LICENSES.txt;md5=e4c045ebad958ead4b48008f70838403 \
11 file://doc/licenses/elementtree.txt;md5=eb34d036a6e3d56314ee49a6852ac891 \
12 file://doc/licenses/BSD.txt;md5=700a1fc17f4797d4f2d34970c8ee694b \
13 file://doc/licenses/GPL.txt;md5=94d55d512a9ba36caa9b7df079bae19f \
14 file://src/lxml/isoschematron/resources/rng/iso-schematron.rng;beginline=2;endline=7;md5=fc85684a8dd5fa272c086bceb0d99e10 \
15 file://src/lxml/isoschematron/resources/xsl/iso-schematron-xslt1/iso_schematron_message.xsl;beginline=2;endline=24;md5=cc86b7b2bbc678e13f58ea403eb9929b \
16 file://src/lxml/isoschematron/resources/xsl/RNG2Schtrn.xsl;beginline=2;endline=7;md5=5b03236d293dc3784205542b409d2f53 \
17 "
18
19DEPENDS += "libxml2 libxslt"
20
21SRC_URI[sha256sum] = "cd11c7e8d21af997ee8079037fff88f16fda188a9776eb4b81c7e4c9c0a7d7fc"
22
23inherit pypi setuptools3
24
25# {standard input}: Assembler messages:
26# {standard input}:1488805: Error: branch out of range
27DEBUG_OPTIMIZATION_remove_mips = " -Og"
28DEBUG_OPTIMIZATION_append_mips = " -O"
29BUILD_OPTIMIZATION_remove_mips = " -Og"
30BUILD_OPTIMIZATION_append_mips = " -O"
31
32DEBUG_OPTIMIZATION_remove_mipsel = " -Og"
33DEBUG_OPTIMIZATION_append_mipsel = " -O"
34BUILD_OPTIMIZATION_remove_mipsel = " -Og"
35BUILD_OPTIMIZATION_append_mipsel = " -O"
36
37BBCLASSEXTEND = "native nativesdk"
38
39RDEPENDS_${PN} += "libxml2 libxslt ${PYTHON_PN}-compression"
40
41CLEANBROKEN = "1"