diff options
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch | 33 |
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch b/meta-python/recipes-devtools/python/python3-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch new file mode 100644 index 0000000000..f4c74384f9 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch | |||
@@ -0,0 +1,33 @@ | |||
1 | From dfb83a41aaeae326e9b6f02b233af375bc7b8815 Mon Sep 17 00:00:00 2001 | ||
2 | From: Koen Kooi <koen@dominion.thruhere.net> | ||
3 | Date: Fri, 29 Mar 2013 15:17:17 +0100 | ||
4 | Subject: [PATCH] setup.py: link in sysroot, not in host directories | ||
5 | |||
6 | Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> | ||
7 | |||
8 | Upstream-status: Unknown | ||
9 | --- | ||
10 | setup.py | 6 +++--- | ||
11 | 1 file changed, 3 insertions(+), 3 deletions(-) | ||
12 | |||
13 | --- a/setup.py | ||
14 | +++ b/setup.py | ||
15 | @@ -135,6 +135,7 @@ class _M2CryptoBuildExt(build_ext.build_ | ||
16 | self.set_undefined_options('build', ('bundledlls', 'bundledlls')) | ||
17 | |||
18 | self.libraries = ['ssl', 'crypto'] | ||
19 | + self.openssl = os.environ.get( "STAGING_DIR" ) | ||
20 | if sys.platform == 'win32': | ||
21 | self.libraries = ['ssleay32', 'libeay32'] | ||
22 | if self.openssl and openssl_version(self.openssl, | ||
23 | @@ -159,8 +160,8 @@ class _M2CryptoBuildExt(build_ext.build_ | ||
24 | |||
25 | if self.openssl is not None: | ||
26 | log.debug('self.openssl = %s', self.openssl) | ||
27 | - openssl_library_dir = os.path.join(self.openssl, 'lib') | ||
28 | - openssl_include_dir = os.path.join(self.openssl, 'include') | ||
29 | + openssl_library_dir = os.environ.get( "STAGING_LIBDIR" ) | ||
30 | + openssl_include_dir = os.environ.get( "STAGING_INCDIR" ) | ||
31 | |||
32 | self.library_dirs.append(openssl_library_dir) | ||
33 | self.include_dirs.append(openssl_include_dir) | ||