summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-matplotlib_3.2.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-matplotlib_3.2.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-matplotlib_3.2.1.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-matplotlib_3.2.1.bb b/meta-python/recipes-devtools/python/python3-matplotlib_3.2.1.bb
new file mode 100644
index 0000000000..f6d8c53d05
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-matplotlib_3.2.1.bb
@@ -0,0 +1,37 @@
1SUMMARY = "matplotlib: plotting with Python"
2DESCRIPTION = "\
3Matplotlib is a Python 2D plotting library which produces \
4publication-quality figures in a variety of hardcopy formats \
5and interactive environments across platforms."
6HOMEPAGE = "https://github.com/matplotlib/matplotlib"
7SECTION = "devel/python"
8LICENSE = "PSF"
9LIC_FILES_CHKSUM = "\
10 file://setup.py;beginline=250;endline=250;md5=2a114620e4e6843aa7568d5902501753 \
11 file://LICENSE/LICENSE;md5=afec61498aa5f0c45936687da9a53d74 \
12"
13DEPENDS = "\
14 freetype \
15 libpng \
16 python3-numpy-native \
17 python3-dateutil-native \
18 python3-pytz-native \
19"
20
21SRC_URI[md5sum] = "6c018a644a88120886cc7211f7c826f0"
22SRC_URI[sha256sum] = "ffe2f9cdcea1086fc414e82f42271ecf1976700b8edd16ca9d376189c6d93aee"
23
24inherit pypi setuptools3 pkgconfig
25
26RDEPENDS_${PN} = "\
27 freetype \
28 libpng \
29 python3-numpy \
30 python3-pyparsing \
31 python3-cycler \
32 python3-dateutil \
33 python3-kiwisolver \
34 python3-pytz \
35"
36
37BBCLASSEXTEND = "native"