diff options
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-ninja')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-ninja/CMakeLists.txt | 9 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-ninja/run-ninja-from-path.patch | 11 |
2 files changed, 20 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-ninja/CMakeLists.txt b/meta-python/recipes-devtools/python/python3-ninja/CMakeLists.txt new file mode 100644 index 0000000000..04fa451e72 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-ninja/CMakeLists.txt | |||
@@ -0,0 +1,9 @@ | |||
1 | cmake_minimum_required(VERSION 3.15) | ||
2 | |||
3 | project(NinjaPythonDistributions) | ||
4 | |||
5 | set(CMAKE_MODULE_PATH ${CMAKE_CURRENT_SOURCE_DIR} ${CMAKE_MODULE_PATH}) | ||
6 | |||
7 | install(CODE " | ||
8 | message(STATUS \"Install ninja project\") | ||
9 | ") | ||
diff --git a/meta-python/recipes-devtools/python/python3-ninja/run-ninja-from-path.patch b/meta-python/recipes-devtools/python/python3-ninja/run-ninja-from-path.patch new file mode 100644 index 0000000000..26bd037373 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-ninja/run-ninja-from-path.patch | |||
@@ -0,0 +1,11 @@ | |||
1 | --- ninja-1.11.1/src/ninja/__init__.py.old 2022-11-05 09:49:23.000000000 +0100 | ||
2 | +++ ninja-1.11.1/src/ninja/__init__.py 2023-03-10 09:45:13.452082888 +0100 | ||
3 | @@ -44,7 +44,7 @@ | ||
4 | |||
5 | |||
6 | def _program(name, args): | ||
7 | - return subprocess.call([os.path.join(BIN_DIR, name)] + args, close_fds=False) | ||
8 | + return subprocess.call([name] + args, close_fds=False) | ||
9 | |||
10 | |||
11 | def ninja(): | ||