summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-nmap_1.4.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-nmap_1.4.8.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-nmap_1.4.8.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-nmap_1.4.8.bb b/meta-python/recipes-devtools/python/python3-nmap_1.4.8.bb
new file mode 100644
index 0000000000..2037d496a6
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-nmap_1.4.8.bb
@@ -0,0 +1,16 @@
1DESCRIPTION = "python-nmap is a python library which helps in using nmap port scanner"
2HOMEPAGE = "https://www.nmmapper.com/"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
6
7DEPENDS += "${PYTHON_PN}-wheel-native"
8
9PYPI_PACKAGE = "python3-nmap"
10
11SRC_URI[md5sum] = "e7904b39b64a8a44f275388862659a0d"
12SRC_URI[sha256sum] = "8d7da78142bee665289a243f71c5f48407d8ab7e5a02ee672ded05f339044759"
13
14inherit pypi setuptools3
15
16RDEPENDS_${PN} += "nmap ${PYTHON_PN}-requests"