summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pandas_1.2.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pandas_1.2.5.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pandas_1.2.5.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pandas_1.2.5.bb b/meta-python/recipes-devtools/python/python3-pandas_1.2.5.bb
new file mode 100644
index 0000000000..71386dc94a
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pandas_1.2.5.bb
@@ -0,0 +1,25 @@
1SUMMARY = "pandas library for high-performance data analysis tools"
2DESCRIPTION = "pandas is an open source, BSD-licensed library providing \
3high-performance, easy-to-use data structures and data analysis tools for \
4the Python programming language."
5HOMEPAGE = "http://pandas.pydata.org/"
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=c2a8f987b2ce77c368c6b3e1b5b10774"
8
9SRC_URI[sha256sum] = "14abb8ea73fce8aebbb1fb44bec809163f1c55241bcc1db91c2c780e97265033"
10
11inherit pypi setuptools3
12
13DEPENDS += " \
14 ${PYTHON_PN}-numpy-native ${PYTHON_PN}-cython-native \
15"
16
17CFLAGS_append_toolchain-clang = " -Wno-error=deprecated-declarations"
18
19RDEPENDS_${PN} += " \
20 ${PYTHON_PN}-json \
21 ${PYTHON_PN}-numpy \
22 ${PYTHON_PN}-dateutil \
23 ${PYTHON_PN}-pytz \
24 ${PYTHON_PN}-profile \
25"