summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pandas_1.3.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pandas_1.3.3.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pandas_1.3.3.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pandas_1.3.3.bb b/meta-python/recipes-devtools/python/python3-pandas_1.3.3.bb
new file mode 100644
index 0000000000..6e557ed7bc
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pandas_1.3.3.bb
@@ -0,0 +1,26 @@
1SUMMARY = "pandas library for high-performance data analysis tools"
2DESCRIPTION = "pandas is an open source, BSD-licensed library providing \
3high-performance, easy-to-use data structures and data analysis tools for \
4the Python programming language."
5HOMEPAGE = "http://pandas.pydata.org/"
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=3f23c5c092b74d245d48eeef72bc3fd2"
8
9SRC_URI[sha256sum] = "272c8cb14aa9793eada6b1ebe81994616e647b5892a370c7135efb2924b701df"
10
11inherit pypi setuptools3
12
13DEPENDS += " \
14 ${PYTHON_PN}-numpy-native ${PYTHON_PN}-cython-native \
15"
16
17CFLAGS:append:toolchain-clang = " -Wno-error=deprecated-declarations"
18
19RDEPENDS:${PN} += " \
20 ${PYTHON_PN}-json \
21 ${PYTHON_PN}-numpy \
22 ${PYTHON_PN}-dateutil \
23 ${PYTHON_PN}-dateutil-zoneinfo \
24 ${PYTHON_PN}-pytz \
25 ${PYTHON_PN}-profile \
26"