diff options
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-prettytable_2.4.0.bb')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-prettytable_2.4.0.bb | 43 |
1 files changed, 43 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-prettytable_2.4.0.bb b/meta-python/recipes-devtools/python/python3-prettytable_2.4.0.bb new file mode 100644 index 0000000000..8f5eb42996 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-prettytable_2.4.0.bb | |||
@@ -0,0 +1,43 @@ | |||
1 | SUMMARY = "Python library for displaying tabular data in a ASCII table format" | ||
2 | HOMEPAGE = "http://code.google.com/p/prettytable" | ||
3 | LICENSE = "BSD-3-Clause" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=c9a6829fcd174d9535b46211917c7671" | ||
5 | |||
6 | SRC_URI[sha256sum] = "18e56447f636b447096977d468849c1e2d3cfa0af8e7b5acfcf83a64790c0aca" | ||
7 | |||
8 | do_install:append() { | ||
9 | perm_files=`find "${D}${PYTHON_SITEPACKAGES_DIR}/" -name "*.txt" -o -name "PKG-INFO"` | ||
10 | for f in $perm_files; do | ||
11 | chmod 644 "${f}" | ||
12 | done | ||
13 | } | ||
14 | |||
15 | UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/PrettyTable/" | ||
16 | UPSTREAM_CHECK_REGEX = "/PrettyTable/(?P<pver>(\d+[\.\-_]*)+)" | ||
17 | |||
18 | BBCLASSEXTEND = "native nativesdk" | ||
19 | inherit pypi ptest setuptools3 | ||
20 | |||
21 | SRC_URI += " \ | ||
22 | file://run-ptest \ | ||
23 | " | ||
24 | |||
25 | DEPENDS += "${PYTHON_PN}-setuptools-scm-native" | ||
26 | |||
27 | RDEPENDS:${PN} += " \ | ||
28 | ${PYTHON_PN}-math \ | ||
29 | ${PYTHON_PN}-html \ | ||
30 | ${PYTHON_PN}-wcwidth \ | ||
31 | ${PYTHON_PN}-json \ | ||
32 | ${PYTHON_PN}-compression \ | ||
33 | ${PYTHON_PN}-importlib-metadata \ | ||
34 | " | ||
35 | |||
36 | RDEPENDS:${PN}-ptest += " \ | ||
37 | ${PYTHON_PN}-pytest \ | ||
38 | ${PYTHON_PN}-sqlite3 \ | ||
39 | " | ||
40 | |||
41 | do_install_ptest() { | ||
42 | cp -f ${S}/tests/test_prettytable.py ${D}${PTEST_PATH}/ | ||
43 | } | ||